Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

L’éditeur de scène Defold

L’éditeur de scène est l’éditeur visuel utilisé pour créer et modifier des scènes, telles que les collections, les objets de jeu (game objects) et d’autres ressources visuelles.

Par défaut, de nombreuses scènes visuelles s’ouvrent avec une vue orthographique 2D. Pour travailler en 3D, vous pouvez passer à une disposition adaptée à la 3D, activer un plan de grille 3D et utiliser une caméra en perspective.

Ouvrir l’éditeur de scène

Ouvrez l’éditeur de scène en double-cliquant sur une ressource visuelle dans le panneau Assets, par exemple :

  • Structure de scène — collections (.collection), objets de jeu (.go)
  • Ressources 2D — atlas (.atlas), tilemaps (.tilemap), sprites (.sprite), sources de tuiles (.tilesource)
  • Ressources 3D — modèles (.model, .glb, .gltf)
  • Interface utilisateur — scènes GUI (.gui)
  • Effets — effets de particules (.particlefx)
  • Et d’autres ressources

Navigation dans la vue de scène (commandes de caméra)

La caméra de l’éditeur de scène se commande à la souris et au clavier. Les commandes disponibles dépendent du mode utilisé : navigation standard ou mode caméra libre.

Navigation standard (tous les éditeurs visuels)

Ces commandes sont disponibles dans les éditeurs visuels :

  • Déplacement panoramique
    • Alt/⌥ Option + Left Mouse Button
  • Zoom
    • Mouse Wheel, ou
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • Rotation/orbite (3D) autour de la sélection
    • Ctrl/^ Control + Left Mouse Button

Vous pouvez aussi utiliser Frame Selection (F) pour centrer la caméra sur la sélection actuelle.

Orientation de la scène en 2D et en 3D {#2d-and-3d-scene-orientation}

La vue de scène peut être utilisée dans les flux de travail en 2D comme en 3D :

  • En 2D, vous travaillez généralement dans une vue orthographique avec une grille orientée pour la 2D.
  • En 3D, vous effectuez généralement les opérations suivantes :
    • Réaligner la vue selon une orientation 3D,
    • Utiliser une caméra en perspective,
    • Choisir un plan de grille approprié (souvent Y pour le « sol »).

Vous pouvez accéder à ces fonctions depuis la barre d’outils et le menu View.

Éditeur de scène en 3D

Présentation de la barre d’outils

En haut à droite de la vue de scène, une barre d’outils rassemble les outils et les options d’affichage courants (de gauche à droite) :

  • Move tool (W)
  • Rotate tool (E)
  • Scale tool (R)
  • Grid Settings ()
  • Align/Realign Camera 2D/3D (2D) — bascule entre les orientations 2D et 3D (raccourci .)
  • Camera Perspective/Orthographic
  • Visibility Filters (👁)

Barre d'outils

Sélectionner et manipuler des objets

Sélectionner des objets

Cliquez avec le bouton gauche de la souris sur les objets dans la fenêtre principale pour les sélectionner. Le rectangle (ou parallélépipède rectangle) entourant l’objet dans la vue de l’éditeur apparaît en cyan pour indiquer l’élément sélectionné. L’objet sélectionné est également mis en évidence dans la vue Outline, comme sur l’image ci-dessus.

Vous pouvez aussi sélectionner des objets de ces façons :

  • Cliquez avec le bouton gauche de la souris et faites glisser pour sélectionner tous les objets à l’intérieur de la zone de sélection.
  • Cliquez avec le bouton gauche de la souris sur les objets dans Outline ; en maintenant ⇧ Shift, vous pouvez étendre la sélection, ou en maintenant Ctrl/⌘ Cmd, vous pouvez sélectionner ou désélectionner les objets sur lesquels vous cliquez.

Outil de déplacement

Outil de déplacement

Pour déplacer des objets, utilisez l’outil Move Tool. Vous le trouverez dans la barre d’outils en haut à droite de l’éditeur de scène, ou en appuyant sur la touche W.

Déplacer un objetDéplacer un objet en 3D

Le gizmo change et affiche un ensemble de poignées de manipulation — carrés et flèches (la poignée sélectionnée devient orange) — que vous pouvez faire glisser pour déplacer l’objet :

  • une poignée carrée cyan au centre pour déplacer l’objet uniquement dans l’espace de l’écran,
  • trois flèches rouge, verte et bleue le long de chaque axe pour déplacer l’objet uniquement selon l’axe X, Y ou Z correspondant.
  • trois poignées carrées rouge, verte et bleue (avec un contour et un remplissage transparent) pour déplacer l’objet uniquement dans le plan correspondant, par exemple X-Y (bleu) et (visibles si vous faites pivoter la caméra en 3D) les plans X-Z (vert) et Y-Z (rouge).

Outil de rotation

Outil de rotation

Pour faire pivoter des objets, utilisez l’outil Rotate Tool en le sélectionnant dans la barre d’outils, ou en appuyant sur la touche E.

Faire pivoter un objetFaire pivoter un objet en 3D

Cet outil comprend quatre poignées de manipulation circulaires (la poignée sélectionnée devient orange) que vous pouvez faire glisser pour faire pivoter l’objet :

  • une poignée cyan (le plus grand cercle, à l’extérieur) qui fait pivoter l’objet dans l’espace de l’écran
  • trois poignées circulaires plus petites, rouge, verte et bleue, qui permettent une rotation autour de chacun des axes X, Y et Z séparément. Dans une vue orthographique 2D, deux d’entre elles sont perpendiculaires aux axes X et Y, de sorte que les cercles n’apparaissent que sous la forme de deux lignes traversant l’objet.

Outil de mise à l’échelle

Outil de mise à l'échelle

Pour mettre des objets à l’échelle, utilisez l’outil Scale Tool en le sélectionnant dans la barre d’outils, ou en appuyant sur la touche R.

Mettre un objet à l'échelleMettre un objet à l'échelle en 3D

Cet outil comprend un ensemble de poignées de manipulation carrées ou cubiques (la poignée sélectionnée devient orange) que vous pouvez faire glisser pour mettre l’objet à l’échelle :

  • un cube cyan au centre met l’objet à l’échelle uniformément sur tous les axes (y compris Z).
  • trois poignées cubiques rouge, bleue et verte mettent l’objet à l’échelle selon chacun des axes X, Y et Z séparément.
  • trois poignées carrées rouge, verte et bleue (avec un contour et un remplissage transparent) mettent l’objet à l’échelle dans les plans X-Y, X-Z ou Y-Z séparément.

Filtres de visibilité

Cliquez sur l’icône en forme d’œil (👁) dans la barre d’outils pour afficher ou masquer différents types de composants (components), ainsi que les boîtes englobantes et les lignes de repère (Component Guides ou le raccourci Ctrl + H (Win/Linux) ou ^ Ctrl + ⌘ Cmd + H(Mac)).

Filtres de visibilité

Paramètres de la grille

Vous pouvez personnaliser la grille pour l’adapter à votre flux de travail (particulièrement utile en 3D). Cliquez sur le bouton Grid Settings () pour ouvrir la fenêtre contextuelle des paramètres de la grille.

Paramètres de la grille

Les paramètres comprennent :

  • Grid size (X/Y/Z) Définit l’espacement entre les lignes de la grille selon chaque axe. Utilisez de petites valeurs pour placer précisément de petits objets, ou de grandes valeurs pour une vue d’ensemble plus large.
  • Active plane (X/Y/Z) Sélectionne le plan sur lequel la grille est tracée. Dans les flux de travail en 2D, il s’agit généralement de Z (le plan X-Y par défaut). Dans les flux de travail en 3D, Y est couramment utilisé pour représenter un plan de sol ou de plancher.
  • Grid color Définit la couleur des lignes de la grille. Utile pour obtenir un contraste adapté aux différents arrière-plans de scène.
  • Grid opacity Contrôle la transparence des lignes de la grille. Des valeurs plus faibles rendent la grille plus discrète tout en conservant un repère.
  • Un bouton Reset to Defaults Rétablit les valeurs d’origine de tous les paramètres de la grille.

Type de caméra : perspective ou orthographique

L’éditeur de scène prend en charge les deux types :

  • Caméra Orthographic (courante dans les flux de travail en 2D)
  • Caméra Perspective (courante dans les flux de travail en 3D)

Utilisez le bouton de bascule de la caméra dans la barre d’outils pour passer de l’un à l’autre. Dans les scènes 3D, la navigation en perspective semble généralement plus naturelle.

Mode caméra libre

Pour naviguer rapidement en 3D, l’éditeur de scène propose un mode caméra libre, une caméra à la première personne, de type « FPS ».

Activer le mode caméra libre

  • Maintenez Right Mouse Button enfoncé — le mode caméra libre est actif tant que le bouton reste enfoncé
  • Shift + ` (accent grave) — active le mode caméra libre, qui reste actif après le relâchement des touches

Sur certaines dispositions de clavier (par exemple suédoises), la touche d’accent grave est une touche morte et peut ne pas déclencher le raccourci comme prévu. Vous pouvez réattribuer ce raccourci dans File ▸ Preferences ▸ Keys et saisir un raccourci pour Scene -> Free Camera -> Activate

Lorsque le mode caméra libre est actif, une ligne souligne les bords de la vue de scène.

Quitter le mode caméra libre

  • Relâchez Right Mouse Button (si le mode a été activé en maintenant le bouton enfoncé), ou
  • Appuyez sur Left Mouse Button ou sur Right Mouse Button (puis relâchez-le), ou appuyez sur Esc si le mode caméra libre a été activé par bascule.

Regarder autour de soi (orientation à la souris)

Lorsque le mode caméra libre est actif, ces commandes contrôlent le mouvement de la caméra (au lieu des outils de l’éditeur) :

  • Déplacez la souris pour contrôler le lacet (gauche/droite) et le tangage (haut/bas)
  • Le tangage est limité pour éviter de retourner la caméra

Vous pouvez aussi inverser l’axe Y si vous le souhaitez (voir les paramètres de la caméra libre ci-dessous).

Se déplacer

Lorsque le mode caméra libre est actif :

  • W — avancer
  • S — reculer
  • A — aller à gauche
  • D — aller à droite
  • E — monter
  • Q — descendre

Toutes les touches de déplacement peuvent être réattribuées dans File ▸ Preferences ▸ Keys. Recherchez ensuite Scene -> Free Camera

Modificateurs de vitesse :

  • Maintenez Shift enfoncé — déplacement plus rapide
  • Maintenez Alt/⌥ Option enfoncé — déplacement plus lent et plus précis

Mode marche (facultatif)

Le mode caméra libre prend en charge le mode marche.

Lorsqu’il est activé :

  • Le déplacement vertical est limité pour se rapprocher d’une marche à la première personne sur un plan de sol.
  • Cela est utile lorsque vous explorez un niveau et souhaitez un déplacement cohérent « au sol ».

Fenêtre contextuelle des paramètres de la caméra

Le bouton de caméra en perspective de la barre d’outils possède une fenêtre contextuelle de paramètres pour les préférences relatives à la caméra.

Paramètres de la caméra en perspective

La fenêtre contextuelle contient :

  • Move Speed Règle la vitesse de déplacement de la caméra libre.

  • Look Sensitivity Règle la vitesse de rotation de la caméra en réponse aux mouvements de la souris.

  • Invert Y Inverse l’orientation verticale à la souris.

  • Walking Mode Limite les déplacements pour une navigation semblable à une marche au sol.

  • Reset to Defaults Rétablit les paramètres par défaut de la caméra.