Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

Defold のシーンエディター

シーンエディター(Scene Editor) は、コレクション(collection)、ゲームオブジェクト(game object)などのシーンや、その他のビジュアルアセットを構築、編集するためのビジュアルエディターです。

既定では、多くのビジュアルシーンは 2D の正投影(orthographic) ビューで開きます。3D での作業では、3D 向けのレイアウトに切り替え、3D のグリッド平面を有効にし、 透視投影(perspective) カメラを使用できます。

シーンエディターを開く

Assets ペインで、次のようなビジュアルリソースをダブルクリックすると、シーンエディターが開きます。

  • シーン構造 — コレクション(.collection)、ゲームオブジェクト(.go
  • 2D アセット — アトラス(atlas、.atlas)、タイルマップ(tilemap、.tilemap)、スプライト(sprite、.sprite)、タイルソース(tile source、.tilesource
  • 3D アセット — モデル(model、.model.glb.gltf
  • UI — GUI シーン(.gui
  • エフェクト — パーティクルエフェクト(particle effect、.particlefx
  • その他

シーンビューの移動(カメラ操作)

シーンエディターのカメラは、マウスとキーボードで操作できます。使用できる操作は、標準のカメラ操作を使用しているか、 フリーカメラモード(Free Camera Mode) を使用しているかによって異なります。

標準の操作(すべてのビジュアルエディター)

ビジュアルエディターでは、次の操作を使用できます。

  • パン
    • Alt/⌥ Option + Left Mouse Button
  • ズーム
    • Mouse Wheel、または
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • 選択対象を中心に回転/周回(3D)
    • Ctrl/^ Control + Left Mouse Button

Frame SelectionF)を使用して、現在の選択対象にカメラを合わせることもできます。

2D と 3D のシーンの向き {#2d-and-3d-scene-orientation}

シーンビューは、2D と 3D の両方のワークフローで使用できます。

  • 2D では、通常、2D 向けのグリッドを表示した正投影ビューで作業します。
  • 3D では、通常、次のように設定します。
    • ビューの向きを 3D 向けに変更します。
    • 透視投影 カメラを使用します。
    • 適切なグリッド平面を選択します(「地面」には Y を使用することがよくあります)。

これらの機能は、ツールバーと View メニューから利用できます。

3D のシーンエディター

ツールバーの概要

シーンビューの右上には、よく使うツールと表示オプションを備えたツールバーがあります(左から右の順)。

  • Move toolW
  • Rotate toolE
  • Scale toolR
  • Grid Settings
  • Align/Realign Camera 2D/3D2D)— 2D と 3D の向きを切り替えます(ショートカットは .)。
  • Camera Perspective/Orthographic
  • Visibility Filters👁

ツールバー

オブジェクトの選択と操作

オブジェクトの選択

メインウィンドウでオブジェクトを 左クリック すると選択できます。エディタービューでオブジェクトを囲む長方形(または直方体)がシアンで強調表示され、どの項目が選択されているかを示します。上の図のように、選択したオブジェクトは Outline ビューでも強調表示されます。

次の方法でもオブジェクトを選択できます。

  • 左クリック して ドラッグ すると、選択領域内のすべてのオブジェクトを選択できます。
  • Outline 内のオブジェクトを 左クリック して選択できます。⇧ Shift を押しながらクリックすると選択範囲を広げられ、Ctrl/⌘ Cmd を押しながらクリックすると、そのオブジェクトの選択と選択解除を切り替えられます。

移動ツール

移動ツール

オブジェクトを移動するには、Move Tool を使用します。シーンエディター右上のツールバーで選択するか、W キーを押して使用できます。

オブジェクトの移動3D でのオブジェクトの移動

ギズモ(gizmo)の表示が変わり、四角形と矢印からなるマニピュレーターが表示されます(選択したマニピュレーターはオレンジ色になります)。これらを ドラッグ して移動できます。

  • 中央にある1つのシアンの四角形のハンドルでは、オブジェクトをスクリーン空間内でのみ移動できます。
  • 各軸に沿った赤、緑、青の3つの矢印では、オブジェクトを対応する X、Y、Z 軸に沿ってのみ移動できます。
  • 赤、緑、青の3つの四角形のハンドル(輪郭があり、内側は透明)では、オブジェクトを対応する平面内でのみ移動できます。たとえば、X-Y 平面(青)や、3D でカメラを回転させると見える X-Z 平面(緑)と Y-Z 平面(赤)です。

回転ツール

回転ツール

オブジェクトを回転するには、ツールバーで Rotate Tool を選択するか、E キーを押します。

オブジェクトの回転3D でのオブジェクトの回転

このツールは4つの円形のマニピュレーターで構成されます(選択したマニピュレーターはオレンジ色になります)。これらを ドラッグ して回転できます。

  • 1つのシアンのマニピュレーター(外側にある最も大きな円)では、オブジェクトをスクリーン空間内で回転できます。
  • 赤、緑、青の3つの小さい円形のマニピュレーターでは、X、Y、Z の各軸を中心に個別に回転できます。2D の正投影ビューでは、そのうち2つが X 軸と Y 軸に対して垂直になるため、円はオブジェクトを横切る2本の線としてのみ表示されます。

拡大縮小ツール

拡大縮小ツール

オブジェクトを拡大縮小するには、ツールバーで Scale Tool を選択するか、R キーを押します。

オブジェクトの拡大縮小3D でのオブジェクトの拡大縮小

このツールは四角形と立方体のマニピュレーターで構成されます(選択したマニピュレーターはオレンジ色になります)。これらを ドラッグ して拡大縮小できます。

  • 中央にある1つのシアンの立方体では、オブジェクトをすべての軸(Z 軸も含む)で均等に拡大縮小できます。
  • 赤、青、緑の3つの立方体のマニピュレーターでは、オブジェクトを X、Y、Z の各軸に沿って個別に拡大縮小できます。
  • 赤、緑、青の3つの四角形のマニピュレーター(輪郭があり、内側は透明)では、オブジェクトを X-Y、X-Z、Y-Z の各平面内で個別に拡大縮小できます。

表示フィルター

ツールバーの Visibility Eye Icon👁)をクリックすると、さまざまな種類のコンポーネント(component)に加え、バウンディングボックスやガイド線の表示を切り替えられます(Component Guides、またはショートカット Ctrl + H(Win/Linux)、^ Ctrl + ⌘ Cmd + H(Mac))。

表示フィルター

グリッドの設定

グリッドはワークフローに合わせてカスタマイズできます(特に 3D で役立ちます)。Grid Settings ボタン()をクリックすると、グリッド設定のポップアップが開きます。

グリッドの設定

次の設定があります。

  • Grid size (X/Y/Z) 各軸に沿ったグリッド線の間隔を設定します。小さなオブジェクトを正確に配置するには小さい値を、広い範囲を見渡すには大きい値を使用します。
  • Active plane (X/Y/Z) グリッドを描画する平面を選択します。2D のワークフローでは通常 Z(既定の X-Y 平面)を使用します。3D のワークフローでは、地面や床の平面を表すために Y を使うのが一般的です。
  • Grid color グリッド線の色を設定します。さまざまなシーンの背景に対してコントラストを確保するのに役立ちます。
  • Grid opacity グリッド線の透明度を制御します。値を小さくすると、配置の目安を保ちながらグリッドを目立たなくできます。
  • Reset to Defaults ボタン グリッドのすべての設定を元の値に戻します。

カメラの種類:透視投影と正投影

シーンエディターは、次の両方に対応しています。

  • 正投影 カメラ(2D のワークフローで一般的)
  • 透視投影 カメラ(3D のワークフローで一般的)

ツールバーのカメラ切り替えボタンで切り替えます。3D シーンでは、通常、透視投影の方が自然に操作できます。

フリーカメラモード

3D 内をすばやく移動できるよう、シーンエディターには一人称視点の「FPS スタイル」のカメラである フリーカメラモード が用意されています。

フリーカメラモードの有効化

  • Right Mouse Button を押し続けます。ボタンを押している間、フリーカメラモードが有効になります。
  • Shift + `(バッククォート)を押すと、フリーカメラモードが有効になり、キーを離した後も有効な状態が続きます。

一部のキーボード配列(スウェーデン語など)では、バッククォートキーがデッドキーであり、ショートカットが想定どおりに動作しない場合があります。 このショートカットは File ▸ Preferences ▸ Keys で割り当て直し、Scene -> Free Camera -> Activate のショートカットを入力できます。

フリーカメラモードが有効な間は、シーンビューの周囲に線が表示され、強調表示されます。

フリーカメラモードの終了

  • 押し続ける操作で有効にした場合は、Right Mouse Button を離します。または、
  • 切り替え操作でフリーカメラモードを有効にした場合は、Left Mouse Button または Right Mouse Button を押して離すか、Esc を押します。

周囲を見回す(マウスによる視点操作)

フリーカメラモードが有効な間は、これらのキーでエディターツールの代わりにカメラの動きを制御します。

  • マウスを動かすと、ヨー(左右)と ピッチ(上下)を制御できます。
  • カメラが反転しないよう、ピッチの範囲は制限されています。

必要に応じて Y 軸を反転することもできます(後述の フリーカメラの設定 を参照してください)。

移動

フリーカメラモードが有効な間は、次のように操作します。

  • W — 前へ
  • S — 後ろへ
  • A — 左へ
  • D — 右へ
  • E — 上へ
  • Q — 下へ

移動用のキーはすべて File ▸ Preferences ▸ Keys で割り当て直せます。そこで Scene -> Free Camera を検索します。

速度を変更する修飾キー:

  • Shift を押し続けると、速く移動します。
  • Alt/⌥ Option を押し続けると、ゆっくり、より正確に移動します。

歩行モード(任意)

フリーカメラモードは Walking Mode(歩行モード)に対応しています。

有効にすると、次のようになります。

  • 地面に立って一人称視点で歩く動きに近づくよう、上下方向の移動が制限されます。
  • レベル内を探索するときに、地面に接した一貫した動きが必要な場合に役立ちます。

カメラ設定のポップアップ

ツールバーの透視投影カメラボタンには、カメラ関連の環境設定を変更するためのポップアップがあります。

透視投影カメラの設定

ポップアップには次の項目があります。

  • Move Speed フリーカメラの移動速度を調整します。

  • Look Sensitivity マウスの動きに対してカメラが回転する速さを調整します。

  • Invert Y マウスによる視点操作の上下方向を反転します。

  • Walking Mode 地面に沿って移動するように動きを制限します。

  • Reset to Defaults カメラの設定を既定値に戻します。