Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

Edytor scen Defold

Scene Editor to edytor wizualny używany do budowania i edytowania scen, takich jak kolekcje, obiekty gry i inne zasoby wizualne.

Początkowy widok kamery zależy od zasobu. Zasoby 3D, takie jak modele i sceny glTF, domyślnie używają widoku perspektywicznego, natomiast zasoby 2D, takie jak sprite’y, mapy kafelków i sceny GUI, używają widoku ortograficznego. Orientację kamery, projekcję i siatkę możesz zmieniać za pomocą paska narzędzi sceny.

Otwieranie edytora scen

Otwórz edytor scen, klikając dwukrotnie zasób wizualny w panelu Assets, na przykład:

  • Struktura sceny - kolekcje (.collection), obiekty gry (.go)
  • Zasoby 2D - atlas (.atlas), mapy kafelków (.tilemap), sprite’y (.sprite), źródła kafelków (.tilesource)
  • Zasoby 3D - modele (.model, .glb, .gltf)
  • UI - sceny GUI (.gui)
  • Efekty - efekty cząsteczkowe (.particlefx)
  • i inne

Zapamiętywanie widoków scen

Edytor zapamiętuje stan kamery dla każdego zasobu sceny przy zamknięciu jego karty lub zakończeniu pracy edytora. Ponowne otwarcie tego samego zasobu przywraca jego widok, dzięki czemu różne kolekcje lub modele mogą zachować różne pozycje, orientacje i projekcje kamery.

Filtry widoczności są również zapamiętywane osobno dla każdej sceny. Ukrycie modeli lub linii pomocniczych komponentów w jednej scenie nie wymaga użycia tych samych filtrów w innej. Są to ustawienia widoku edytora i nie zmieniają kamery gry ani widoczności w czasie działania.

Zasoby modeli, siatek i glTF bez zapisanego stanu kamery otwierają się w perspektywie. Obiekty kolizji wybierają widok na podstawie ustawienia fizyki 2D/3D projektu, a kolekcje i obiekty gry wybierają widok początkowy na podstawie geometrii sceny.

Nawigacja widoku sceny (sterowanie kamerą)

Kamerą edytora scen można sterować myszą i klawiaturą. Dostępne sterowanie zależy od tego, czy używasz standardowej nawigacji kamery, czy Free Camera Mode.

Standardowa nawigacja (wszystkie edytory wizualne)

Te działania są dostępne w edytorach wizualnych:

  • Przesuwanie
    • Alt/⌥ Option + Left Mouse Button
  • Przybliżanie
    • Mouse Wheel albo
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • Obrót/orbita wokół zaznaczenia (3D)
    • Ctrl/^ Control + Left Mouse Button

Możesz też użyć Frame Selection (F), aby ustawić kamerę na bieżącym zaznaczeniu.

Orientacja sceny 2D i 3D

Widok sceny może być używany zarówno w przepływie pracy 2D, jak i 3D:

  • W 2D zwykle pracujesz w widoku ortograficznym z siatką zorientowaną na 2D.
  • W 3D zwykle:
    • zmieniasz orientację widoku na 3D,
    • używasz kamery perspektywicznej,
    • wybierasz odpowiednią płaszczyznę siatki, często Y jako „podłoże”.

Te funkcje są dostępne z paska narzędzi oraz menu View.

Edytor scen 3D

Przegląd paska narzędzi

W prawym górnym rogu widoku sceny znajduje się pasek narzędzi z często używanymi narzędziami i opcjami widoku (od lewej do prawej):

  • Move tool (W)
  • Rotate tool (E)
  • Scale tool (R)
  • Grid Settings ()
  • Align/Realign Camera 2D/3D (2D) - przełącza orientację 2D i 3D (skrót .)
  • Camera Perspective/Orthographic
  • Visibility Filters (👁)

Pasek narzędzi

Zaznaczanie i manipulowanie obiektami

Zaznaczanie obiektów

Kliknij obiekt w głównym oknie przyciskiem Left Mouse Click, aby go zaznaczyć. Prostokąt lub prostopadłościan otaczający obiekt w widoku edytora zostanie podświetlony na kolor cyjan, wskazując zaznaczony element. Zaznaczony obiekt zostanie też podświetlony w widoku Outline, jak na ilustracji powyżej.

Obiekty można też zaznaczać w następujący sposób:

  • Left Mouse Click i Drag, aby zaznaczyć wszystkie obiekty w obszarze zaznaczenia.
  • Left Mouse Click na obiektach w Outline; przytrzymując ⇧ Shift, możesz rozszerzać zaznaczenie, a przytrzymując Ctrl/⌘ Cmd, zaznaczać lub odznaczać kliknięte elementy.

Move tool

Move tool

Aby przesuwać obiekty, użyj Move Tool. Znajdziesz je na pasku narzędzi w prawym górnym rogu edytora scen albo włączysz klawiszem W.

Przesuwanie obiektuPrzesuwanie obiektu 3D

Gizmo zmienia się i pokazuje zestaw manipulatorów - kwadratów i strzałek. Zaznaczony manipulator zmienia kolor na pomarańczowy. Możesz je Drag, aby przesuwać:

  • jeden cyjanowy środkowy kwadrat, który przesuwa obiekt tylko w przestrzeni ekranu,
  • 3 czerwone, zielone i niebieskie strzałki wzdłuż osi, które przesuwają obiekt tylko po danej osi X, Y lub Z,
  • 3 czerwone, zielone i niebieskie kwadratowe uchwyty z przezroczystym wypełnieniem, które przesuwają obiekt tylko po danej płaszczyźnie, np. X-Y (niebieska), a po obrocie kamery w 3D także X-Z (zielona) i Y-Z (czerwona).

Rotate tool

Rotate tool

Aby obracać obiekty, użyj Rotate Tool, wybierając je na pasku narzędzi albo naciskając E.

Obracanie obiektuObracanie obiektu 3D

To narzędzie składa się z czterech okrągłych manipulatorów, które możesz Drag, aby obracać. Zaznaczony manipulator zmienia kolor na pomarańczowy:

  • jeden cyjanowy manipulator, zewnętrzny i największy, obracający obiekt w przestrzeni ekranu,
  • 3 mniejsze czerwone, zielone i niebieskie okrągłe manipulatory pozwalające obracać osobno wokół osi X, Y i Z. W ortograficznym widoku 2D dwa z nich są prostopadłe do osi X i Y, więc okręgi są widoczne tylko jako dwie linie przecinające obiekt.

Scale tool

Scale tool

Aby skalować obiekty, użyj Scale Tool, wybierając je na pasku narzędzi albo naciskając R.

Skalowanie obiektuSkalowanie obiektu 3D

To narzędzie składa się z zestawu kwadratowych lub sześciennych manipulatorów, które możesz Drag, aby skalować. Zaznaczony manipulator zmienia kolor na pomarańczowy:

  • jeden cyjanowy sześcian w środku skaluje obiekt równomiernie we wszystkich osiach, także w osi Z,
  • 3 czerwone, niebieskie i zielone sześcienne manipulatory skalują obiekt osobno wzdłuż osi X, Y i Z,
  • 3 czerwone, zielone i niebieskie kwadratowe manipulatory z przezroczystym wypełnieniem skalują obiekt osobno na płaszczyznach X-Y, X-Z lub Y-Z.

Filtry widoczności

Kliknij ikonę oka (👁) na pasku narzędzi, aby przełączać widoczność różnych typów komponentów oraz obwiedni i linii pomocniczych (Component Guides albo skrót Ctrl + H w Windows/Linux lub ^ Ctrl + ⌘ Cmd + H na Macu).

Filtry widoczności

Ustawienia siatki

Siatkę można dostosować do swojego przepływu pracy, co jest szczególnie przydatne w 3D. Kliknij przycisk Grid Settings (), aby otworzyć okno ustawień siatki.

Edytor przechowuje osobne ustawienia siatki dla widoków 2D i 3D. Ustaw rozmiar, płaszczyznę i wygląd, gdy aktywny jest właściwy tryb; przełączenie trybu przywraca jego ustawienia siatki. Reset to Defaults resetuje ustawienia aktywnego trybu.

Ustawienia siatki

Ustawienia obejmują:

  • Grid size (X/Y/Z) Ustawia odstęp między liniami siatki wzdłuż każdej osi. Użyj mniejszych wartości do precyzyjnego rozmieszczania małych obiektów albo większych wartości do szerszego przeglądu.
  • Active plane (X/Y/Z) Wybiera płaszczyznę, na której rysowana jest siatka. W przepływie pracy 2D jest to zwykle Z, czyli domyślna płaszczyzna X-Y. W przepływie pracy 3D często używa się Y, aby reprezentować podłoże.
  • Grid color Ustawia kolor linii siatki. Przydaje się do uzyskania kontrastu z różnymi tłami sceny.
  • Grid opacity Kontroluje przezroczystość linii siatki. Niższe wartości sprawiają, że siatka mniej przeszkadza, ale nadal służy jako punkt odniesienia.
  • Przycisk Reset to Defaults Przywraca ustawienia siatki aktywnego trybu do wartości początkowych.

Typ kamery: Perspective i Orthographic

Edytor scen obsługuje oba typy:

  • kamerę Orthographic, typową w przepływie pracy 2D,
  • kamerę Perspective, typową w przepływie pracy 3D.

Do przełączania użyj przełącznika kamery na pasku narzędzi. W scenach 3D nawigacja perspektywiczna zwykle jest bardziej naturalna.

Free Camera Mode

Do szybkiej nawigacji 3D edytor scen udostępnia Free Camera Mode, czyli kamerę pierwszoosobową w stylu FPS.

Włączanie Free Camera Mode

  • Przytrzymaj Right Mouse Button - Free Camera Mode działa tak długo, jak przycisk jest trzymany.
  • Shift + ` (backtick) - przełącza Free Camera Mode na stałe, pozostawiając go aktywnym po puszczeniu klawiszy.

Na niektórych układach klawiatury, np. szwedzkim, klawisz backtick jest martwym klawiszem i skrót może nie zadziałać zgodnie z oczekiwaniami. Ten skrót można zmienić w File ▸ Preferences ▸ Keys, wpisując skrót dla Scene -> Free Camera -> Activate.

Gdy Free Camera Mode jest aktywny, Scene View jest podświetlony linią wokół krawędzi.

Wyłączanie Free Camera Mode

  • Puść Right Mouse Button, jeśli tryb był aktywowany przytrzymaniem, albo
  • naciśnij i puść Left Mouse Button, Right Mouse Button albo naciśnij Esc, jeśli Free Camera Mode został włączony przełącznikiem.

Rozglądanie się (mouse look)

Gdy Free Camera Mode jest aktywny, te działania sterują ruchem kamery zamiast narzędziami edytora:

  • Poruszaj myszą, aby kontrolować yaw (lewo/prawo) i pitch (góra/dół).
  • Pitch jest ograniczony, aby kamera się nie odwróciła.

Możesz też opcjonalnie odwrócić oś Y; zobacz Free camera settings niżej.

Poruszanie

Gdy Free Camera Mode jest aktywny:

  • W - do przodu
  • S - do tyłu
  • A - w lewo
  • D - w prawo
  • E - w górę
  • Q - w dół

Wszystkie klawisze ruchu można zmienić w File ▸ Preferences ▸ Keys. Następnie wyszukaj Scene -> Free Camera.

Modyfikatory prędkości:

  • Przytrzymaj Shift - szybszy ruch
  • Przytrzymaj Alt/⌥ Option - wolniejszy, dokładniejszy ruch

Walking mode (opcjonalnie)

Free Camera Mode obsługuje Walking Mode.

Gdy jest włączony:

  • ruch w górę i w dół jest ograniczony tak, aby bardziej przypominał chodzenie po podłożu z perspektywy pierwszej osoby,
  • jest to przydatne podczas eksplorowania poziomu, gdy chcesz zachować spójny ruch „po ziemi”.

Okno ustawień kamery

Przycisk kamery perspektywicznej na pasku narzędzi ma okno ustawień związanych z kamerą.

Ustawienia kamery perspektywicznej

Okno zawiera:

  • Move Speed Dostosowuje prędkość ruchu swobodnej kamery.

  • Look Sensitivity Dostosowuje szybkość obrotu kamery w odpowiedzi na ruch myszy.

  • Invert Y Odwraca pionowy kierunek rozglądania się myszą.

  • Walking Mode Ogranicza ruch do nawigacji przypominającej poruszanie się po podłożu.

  • Reset to Defaults Przywraca domyślne ustawienia kamery.