Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

Редактор сцени Defold

Редактор сцени (Scene Editor) — це візуальний редактор для створення й редагування сцен, зокрема колекцій (collection), ігрових об’єктів (game object) та інших візуальних ресурсів.

За замовчуванням багато візуальних сцен відкриваються в ортографічному 2D-вигляді. Для роботи у 3D ви можете перемкнутися на орієнтоване на 3D компонування, увімкнути площину сітки для 3D та використовувати перспективну камеру.

Відкриття редактора сцени

Щоб відкрити редактор сцени, двічі клацніть візуальний ресурс на панелі Assets, наприклад:

  • Структура сцени — колекції (.collection), ігрові об’єкти (.go)
  • 2D-ресурси — атлас (.atlas), карти плиток (.tilemap), спрайти (.sprite), джерела плиток (.tilesource)
  • 3D-ресурси — моделі (.model, .glb, .gltf)
  • Інтерфейс користувача — сцени GUI (.gui)
  • Ефекти — ефекти частинок (.particlefx)
  • Та інші

Навігація в області перегляду сцени (керування камерою)

Камерою редактора сцени можна керувати за допомогою миші та клавіатури. Доступні способи керування залежать від того, чи використовуєте ви стандартну навігацію камерою, чи режим вільної камери (Free Camera Mode).

Стандартна навігація (усі візуальні редактори)

У візуальних редакторах доступні такі способи керування:

  • Панорамування
    • Alt/⌥ Option + Left Mouse Button
  • Масштабування
    • Mouse Wheel або
    • Ctrl/^ Control + Alt/⌥ Option + Left Mouse Button
  • Поворот/обертання (3D) навколо виділення
    • Ctrl/^ Control + Left Mouse Button

Ви також можете скористатися Frame Selection (F), щоб сфокусувати камеру на поточному виділенні.

Орієнтація сцени у 2D та 3D {#2d-and-3d-scene-orientation}

Область перегляду сцени можна використовувати як для роботи у 2D, так і для роботи у 3D:

  • У 2D ви зазвичай працюєте з ортографічним виглядом і сіткою, орієнтованою на 2D.
  • У 3D ви зазвичай:
    • Змінюєте орієнтацію вигляду на 3D,
    • Використовуєте перспективну камеру,
    • Вибираєте відповідну площину сітки (часто Y для «землі»).

Ці функції доступні на панелі інструментів і в меню View.

Редактор сцени у 3D

Огляд панелі інструментів

У верхньому правому куті області перегляду сцени розташована панель інструментів із часто використовуваними інструментами й параметрами перегляду (зліва направо):

  • Move tool (W)
  • Rotate tool (E)
  • Scale tool (R)
  • Grid Settings ()
  • Align/Realign Camera 2D/3D (2D) — перемикає між орієнтаціями 2D та 3D (скорочення .)
  • Camera Perspective/Orthographic
  • Visibility Filters (👁)

Панель інструментів

Виділення об’єктів і маніпулювання ними

Виділення об’єктів

Клацніть лівою кнопкою миші об’єкти в головному вікні, щоб виділити їх. Прямокутник (або прямокутний паралелепіпед), що оточує об’єкт в області перегляду редактора, підсвітиться блакитним, позначаючи виділений елемент. Виділений об’єкт також підсвічується на панелі Outline, як на зображенні вище.

Ви також можете виділяти об’єкти так:

  • Клацніть лівою кнопкою миші та перетягніть, щоб виділити всі об’єкти всередині області виділення.
  • Клацніть лівою кнопкою миші об’єкти на панелі Outline; утримуючи ⇧ Shift, ви можете розширити виділення, а утримуючи Ctrl/⌘ Cmd — виділити об’єкт, який клацнули, або зняти з нього виділення.

Інструмент переміщення

Інструмент переміщення

Щоб переміщувати об’єкти, використовуйте Move Tool. Його можна вибрати на панелі інструментів у верхньому правому куті редактора сцени або натисканням клавіші W.

Переміщення об’єктаПереміщення об’єкта у 3D

Гізмо змінюється й показує набір маніпуляторів — квадратів і стрілок (вибраний маніпулятор стає помаранчевим), які можна перетягувати для переміщення:

  • один блакитний квадратний маніпулятор у центрі переміщує об’єкт лише в екранному просторі,
  • 3 стрілки вздовж осей — червона, зелена й синя — переміщують об’єкт лише вздовж відповідної осі X, Y або Z.
  • 3 квадратні маніпулятори — червоний, зелений і синій (контурні, з прозорою заливкою) — переміщують об’єкт лише у відповідній площині, наприклад X-Y (синій), а також у площинах X-Z (зелений) і Y-Z (червоний), які видно, якщо обертати камеру у 3D.

Інструмент повороту

Інструмент повороту

Щоб повертати об’єкти, використовуйте Rotate Tool, вибравши його на панелі інструментів або натиснувши клавішу E.

Поворот об’єктаПоворот об’єкта у 3D

Цей інструмент складається з чотирьох кругових маніпуляторів (вибраний маніпулятор стає помаранчевим), які можна перетягувати для повороту:

  • один блакитний маніпулятор (зовнішнє, найбільше коло) повертає об’єкт в екранному просторі
  • 3 менші кругові маніпулятори — червоний, зелений і синій — дають змогу окремо повертати об’єкт навколо кожної з осей X, Y та Z. В ортографічному 2D-вигляді два з них перпендикулярні до осей X та Y, тому ці кола мають вигляд двох ліній, що перетинають об’єкт.

Інструмент масштабування

Інструмент масштабування

Щоб масштабувати об’єкти, використовуйте Scale Tool, вибравши його на панелі інструментів або натиснувши клавішу R.

Масштабування об’єктаМасштабування об’єкта у 3D

Цей інструмент складається з набору квадратних/кубічних маніпуляторів (вибраний маніпулятор стає помаранчевим), які можна перетягувати для масштабування:

  • один блакитний куб у центрі рівномірно масштабує об’єкт уздовж усіх осей (зокрема Z).
  • 3 кубічні маніпулятори — червоний, синій і зелений — масштабують об’єкт окремо вздовж кожної з осей X, Y та Z.
  • 3 квадратні маніпулятори — червоний, зелений і синій (контурні, з прозорою заливкою) — масштабують об’єкт окремо у площинах X-Y, X-Z або Y-Z.

Фільтри видимості

Клацніть Visibility Eye Icon (👁) на панелі інструментів, щоб перемикати видимість різних типів компонентів (component), а також обмежувальних рамок і напрямних ліній (Component Guides або скорочення Ctrl + H (Win/Linux) чи ^ Ctrl + ⌘ Cmd + H(Mac)).

Фільтри видимості

Налаштування сітки

Сітку можна налаштувати відповідно до вашого способу роботи (особливо корисно у 3D). Натисніть кнопку Grid Settings (), щоб відкрити спливну панель налаштувань сітки.

Налаштування сітки

Серед налаштувань:

  • Grid size (X/Y/Z) Задає відстань між лініями сітки вздовж кожної осі. Використовуйте менші значення для точного розміщення малих об’єктів або більші значення для ширшого огляду.
  • Active plane (X/Y/Z) Вибирає площину, у якій відображається сітка. Під час роботи у 2D це зазвичай Z (площина X-Y за замовчуванням). Під час роботи у 3D часто використовують Y, щоб позначити площину землі/підлоги.
  • Grid color Задає колір ліній сітки. Це корисно для контрасту з різними фонами сцени.
  • Grid opacity Керує прозорістю ліній сітки. За менших значень сітка менше відволікає, але залишається орієнтиром.
  • Кнопка Reset to Defaults Відновлює початкові значення всіх налаштувань сітки.

Тип камери: перспективна й ортографічна

Редактор сцени підтримує обидва типи:

  • Камеру Orthographic (зазвичай використовується для роботи у 2D)
  • Камеру Perspective (зазвичай використовується для роботи у 3D)

Для перемикання використовуйте перемикач камери на панелі інструментів. У 3D-сценах навігація з перспективною камерою зазвичай відчувається природнішою.

Режим вільної камери

Для швидкої навігації у 3D редактор сцени пропонує режим вільної камери — камеру від першої особи / «у стилі FPS».

Увімкнення режиму вільної камери

  • Утримуйте Right Mouse Button — режим вільної камери активний, доки ви утримуєте кнопку
  • Shift + ` (зворотна лапка) — вмикає режим вільної камери, який залишається активним після відпускання клавіш

У деяких розкладках клавіатури (наприклад, шведській) клавіша зворотної лапки є «мертвою» клавішею, і скорочення може не спрацювати належним чином. Ви можете перепризначити це скорочення в File ▸ Preferences ▸ Keys, задавши скорочення для Scene -> Free Camera -> Activate

Коли режим вільної камери активний, область перегляду сцени підсвічується лінією вздовж країв.

Вихід із режиму вільної камери

  • Відпустіть Right Mouse Button (якщо режим увімкнено утриманням кнопки) або
  • Натисніть Left Mouse Button, Right Mouse Button (натисніть і відпустіть) або клавішу Esc, якщо режим вільної камери увімкнено перемиканням.

Огляд довкола (керування поглядом за допомогою миші)

Коли режим вільної камери активний, ці клавіші керують рухом камери (замість інструментів редактора):

  • Рухайте мишею, щоб керувати поворотом (ліворуч/праворуч) і нахилом (угору/вниз)
  • Кут нахилу обмежений, щоб камера не переверталася

За бажанням ви також можете інвертувати вісь Y (див. Налаштування вільної камери нижче).

Переміщення

Коли режим вільної камери активний:

  • W — уперед
  • S — назад
  • A — ліворуч
  • D — праворуч
  • E — угору
  • Q — униз

Усі клавіші переміщення можна перепризначити в File ▸ Preferences ▸ Keys. Далі знайдіть Scene -> Free Camera

Модифікатори швидкості:

  • Утримуйте Shift — рухайтеся швидше
  • Утримуйте Alt/⌥ Option — рухайтеся повільніше / точніше

Режим ходьби (необов’язковий)

Режим вільної камери підтримує Walking Mode.

Коли його ввімкнено:

  • Рух угору/вниз обмежений, щоб він більше нагадував ходьбу від першої особи по площині землі.
  • Це корисно під час огляду рівня, коли потрібен послідовний рух «по землі».

Спливна панель налаштувань камери

Кнопка перспективної камери на панелі інструментів має спливну панель із налаштуваннями камери.

Налаштування перспективної камери

Спливна панель містить:

  • Move Speed Регулює швидкість переміщення вільної камери.

  • Look Sensitivity Регулює швидкість повороту камери у відповідь на рух миші.

  • Invert Y Інвертує вертикальний напрямок керування поглядом за допомогою миші.

  • Walking Mode Обмежує рух для навігації, подібної до руху по землі.

  • Reset to Defaults Відновлює налаштування камери за замовчуванням.