Manuals
Manuals




This translation is community contributed and may not be up to date. We only maintain the English version of the documentation. Read this manual in English

Panoramica dell’editor

L’editor consente di esplorare e gestire in modo efficiente tutti i file e le cartelle del progetto di gioco. Quando apri un file per modificarlo, viene mostrato l’editor adatto al suo tipo, con tutte le informazioni pertinenti suddivise in viste separate.

Avvio dell’editor

Quando avvii l’editor Defold, viene mostrata una schermata per selezionare e creare progetti. Fai clic per scegliere che cosa vuoi fare:

MY PROJECTS
Qui trovi i progetti aperti di recente, per potervi accedere rapidamente. È la vista predefinita della schermata iniziale.

Se non hai ancora aperto alcun progetto (o li hai rimossi tutti), vengono mostrati due pulsanti: puoi fare clic su Open From Disk… per cercare e aprire un progetto tramite il gestore di file del sistema, oppure sul pulsante Create New Project per passare alla scheda TEMPLATES.

I miei progetti

Se hai già aperto dei progetti, viene mostrato il relativo elenco, come nell’immagine seguente:

I miei progetti

TEMPLATES
Contiene progetti di base vuoti o quasi vuoti, pensati per avviare rapidamente un nuovo progetto Defold per determinate piattaforme o con determinate estensioni.
TUTORIALS
Contiene progetti con tutorial guidati da cui imparare, con cui giocare e da modificare, se preferisci seguire un tutorial.
SAMPLES
Contiene progetti preparati per illustrare casi d’uso specifici.

Nuovo progetto

Quando crei un nuovo progetto, questo viene salvato sul disco locale e anche tutte le modifiche vengono salvate localmente.

Puoi approfondire le diverse opzioni nel manuale sulla configurazione del progetto.

Lingua dell’editor

Nell’angolo in basso a sinistra della schermata iniziale trovi un selettore della lingua: scegli tra le localizzazioni attualmente disponibili. Questa opzione è disponibile anche nell’editor in File ▸ Preferences ▸ General ▸ Editor Language.

Lingue

I pannelli dell’editor

L’editor Defold è suddiviso in una serie di pannelli, o viste, che mostrano informazioni specifiche.

Editor 2

1. Pannello Assets {#1-assets-pane}

Elenca tutti i file e le cartelle che fanno parte del progetto in una struttura ad albero, corrispondente a quella presente sul disco. Fai clic e scorri per esplorare l’elenco. In questa vista puoi eseguire tutte le operazioni sui file:

  • Fai clic con il pulsante sinistro del mouse per selezionare un file o una cartella; tenendo premuto ⇧ Shift puoi estendere la selezione, mentre tenendo premuto Ctrl/⌘ Cmd puoi selezionare o deselezionare l’elemento su cui fai clic.
  • Fai doppio clic su un file per aprirlo nell’editor specifico per quel tipo di file.
  • Trascina e rilascia per aggiungere al progetto file da altre posizioni sul disco oppure per spostare file e cartelle in nuove posizioni all’interno del progetto.
  • Fai clic con il pulsante destro del mouse per aprire un menu contestuale da cui puoi creare nuovi file o cartelle, rinominarli, eliminarli, esaminare le dipendenze dei file e altro ancora.

I file e le cartelle eliminati tramite il pannello Assets vengono spostati nel cestino del sistema, se la piattaforma lo supporta. Se lo spostamento nel cestino non è supportato o non riesce, l’editor li elimina definitivamente.

2. Pannello Scene Editor

Facendo doppio clic su un file di collezione, oggetto di gioco o componente visivo, si apre lo Scene Editor, l’editor visivo per creare e modificare le scene. I file di script e le altre risorse non visive si aprono invece nei rispettivi editor dedicati.

Editor della scena

Alcune delle funzionalità principali dell’editor della scena:

Per saperne di più, consulta il manuale dell’editor della scena.

3. Pannello Outline {#3-outline-pane}

Questa vista mostra il contenuto del file che stai modificando in una struttura gerarchica ad albero. La vista Outline rispecchia la vista dell’editor e consente di eseguire operazioni sugli elementi:

  • Fai clic con il pulsante sinistro del mouse per selezionare un elemento; tenendo premuto ⇧ Shift puoi estendere la selezione, mentre tenendo premuto Ctrl/⌘ Cmd puoi selezionare o deselezionare l’elemento su cui fai clic.
  • Trascina e rilascia per spostare gli elementi. Rilascia un oggetto di gioco su un altro oggetto di gioco in una collezione per creare una relazione genitore-figlio.
  • Fai clic con il pulsante destro del mouse per aprire un menu contestuale da cui puoi aggiungere elementi, eliminare quelli selezionati e così via.

Puoi mostrare o nascondere gli oggetti di gioco e i componenti visivi facendo clic sulla piccola icona a forma di occhio 👁 a destra di un elemento nell’elenco.

Struttura degli elementi

4. Pannello Properties {#4-properties-pane}

Questa vista mostra le proprietà associate all’elemento selezionato, come Id, URL, Position, Rotation, Scale e altre proprietà specifiche del componente, oltre alle proprietà personalizzate degli script.

Puoi anche trascinare la freccia verticale e muovere il mouse per cambiare il valore della proprietà numerica corrispondente.

Proprietà

5. Pannello Tools {#5-tools-pane}

Questa vista contiene diverse schede.

Scheda Console : mostra gli errori, gli avvisi e le informazioni emessi dal motore, oltre all’output che produci esplicitamente mentre il gioco è in esecuzione,

Build Errors : mostra gli errori del processo di build,

Search Results : mostra i risultati della ricerca (Ctrl/⌘ Cmd + Shift + F) nell’intero progetto, se fai clic su Keep Results

Curve Editor : viene usato per modificare le curve nell’editor delle particelle.

Il pannello Tools viene usato anche per interagire con il debugger integrato. Per saperne di più, consulta il manuale sul debug.

6. Pannello Changed Files {#6-changed-files-pane}

Se il progetto usa Git, questa vista elenca i file modificati, aggiunti, rinominati o eliminati localmente rispetto al commit corrente (HEAD). Usa un client Git esterno o la riga di comando per sincronizzarti con un repository remoto. Puoi saperne di più nel manuale sul controllo di versione. In questa vista puoi eseguire alcune operazioni sui file:

  • Fai clic con il pulsante sinistro del mouse - per selezionare un file; tenendo premuto ⇧ Shift puoi estendere la selezione, mentre tenendo premuto Ctrl/⌘ Cmd puoi selezionare o deselezionare l’elemento su cui fai clic. Se è selezionato un solo file modificato, puoi fare clic su Diff per visualizzarne le differenze. Puoi fare clic su Revert per annullare le modifiche in tutti i file selezionati.
  • Fai doppio clic con il pulsante sinistro del mouse su un file per aprirne una vista. L’editor apre il file nell’editor adatto, come nella vista Assets.
  • Fai clic con il pulsante destro del mouse su un file per aprire un menu da cui puoi visualizzare le differenze, annullare tutte le modifiche apportate al file, individuare il file nel file system e altro ancora.

Nella parte superiore della vista dell’editor, oppure nella barra di sistema su Mac, trovi la barra dei menu con 6 menu: File, Edit, View, Project, Debug, Help. Le loro funzioni sono spiegate nei manuali.

Barra di stato

Nella barra inferiore dell’editor trovi una piccola area in cui viene mostrato lo stato, ad esempio:

  • quando è disponibile un nuovo aggiornamento, compare il pulsante Update Available: consulta la sezione Aggiornamento dell’editor più avanti in questo manuale.
  • durante la creazione di una build o di un bundle, viene mostrato l’avanzamento dell’operazione.

Dimensioni e visibilità dei pannelli

Puoi regolare le dimensioni dei pannelli nell’editor trascinando i bordi delle sezioni che separano i 6 pannelli descritti sopra.

Puoi mostrare o nascondere i pannelli dell’editor usando le opzioni del menu View o le relative scorciatoie:

  • Toggle Assets Pane (F6) per mostrare o nascondere i pannelli Assets e Changed Files
  • Toggle Changed Files per mostrare o nascondere soltanto il pannello Changed Files
  • Toggle Tools Pane (F7) per mostrare o nascondere il pannello Tools
  • Toggle Properties Pane (F8) per mostrare o nascondere i pannelli Outline e Properties

Visibilità dei pannelli

Nel menu View puoi anche attivare, disattivare o modificare altre impostazioni di visualizzazione, come Grid, Guides o Camera, inquadrare la selezione (Frame Selection o tasto F) e passare dalla vista predefinita 2D a quella 3D e viceversa (Realign Camera o tasto .). Molte di queste opzioni sono accessibili anche dalla barra degli strumenti o tramite scorciatoie.

Schede

Se hai più file aperti, nella parte superiore della vista dell’editor viene mostrata una scheda per ciascun file. Puoi riordinare le schede all’interno di un pannello: trascinale e rilasciale per scambiarne la posizione nella barra delle schede. Puoi anche:

  • Fare clic con il pulsante destro del mouse su una scheda per aprire un menu contestuale,
  • Fare clic su Close (Ctrl/⌘ Cmd + W) per chiudere una singola scheda,
  • Fare clic su Close Others per chiudere tutte le schede tranne quella selezionata,
  • Fare clic su Close All (Ctrl/⌘ Cmd + Shift+W) per chiudere tutte le schede del pannello attivo,
  • Selezionare ➝| Open As - per usare un editor diverso da quello predefinito o lo strumento esterno associato impostato in File ▸ Preferences ▸ Code ▸ Custom Editor. Per saperne di più, consulta il manuale delle preferenze.

Schede

Modifica in viste affiancate

Puoi aprire 2 viste dell’editor una accanto all’altra.

  • Fai clic con il pulsante destro del mouse sulla scheda dell’editor che vuoi spostare e seleziona Move to Other Tab Pane.

2 pannelli

Puoi anche usare il menu della scheda e scegliere Swap with Other Tab Pane per spostare una scheda da un pannello all’altro, oppure Join Tab Panes per riunire i pannelli in uno solo.

Creazione di nuovi file di progetto

Per creare nuovi file di risorse, seleziona File ▸ New… e scegli il tipo di file dal menu, oppure usa il menu contestuale:

Fai clic con il pulsante destro del mouse sulla posizione di destinazione nella vista Assets, quindi seleziona New… ▸ [file type]:

Creazione di un file

Digita un nome appropriato per il nuovo file in Name ed eventualmente cambia Location. Il nome completo del file, compresa l’estensione che ne indica il tipo, viene mostrato sotto Preview nella finestra di dialogo:

Nome del nuovo file

Modelli

Puoi specificare modelli personalizzati per ogni progetto. Per farlo, crea una nuova cartella chiamata templates nella directory radice del progetto e aggiungi nuovi file chiamati default.* con le estensioni desiderate, ad esempio /templates/default.gui o /templates/default.script. Inoltre, se in questi file viene usato il token {{NAME}}, questo verrà sostituito con il nome del file specificato nella finestra di creazione del file.

Se è disponibile un modello per un determinato tipo di file, ogni nuovo file di quel tipo viene inizializzato con il contenuto del file corrispondente in templates.

Modelli

Importazione di file nel progetto

Per aggiungere file di asset (immagini, suoni, modelli e così via) al progetto, trascinali e rilasciali nella posizione corretta della vista Assets. Vengono create delle copie dei file nella posizione selezionata all’interno della struttura dei file del progetto. Per saperne di più, consulta il manuale sull’importazione degli asset.

Importazione di file

Aggiornamento dell’editor

L’editor verifica automaticamente la disponibilità di aggiornamenti quando è connesso a Internet. Quando viene rilevato un aggiornamento, viene mostrato il link blu Update Available nell’angolo in basso a sinistra della schermata di selezione del progetto o nell’angolo in basso a destra della finestra dell’editor.

Aggiornamento dalla selezione del progetto Aggiornamento dall'editor

Fai clic sul link Update Available per scaricare e installare l’aggiornamento. Si apre una finestra di conferma con le informazioni: fai clic su Download Update per procedere.

Finestra di aggiornamento dell'editor

L’avanzamento del download viene mostrato nella barra di stato inferiore:

Avanzamento del download

Una volta scaricato l’aggiornamento, il link blu diventa Restart to Update. Fai clic per riavviare e aprire l’editor aggiornato.

Riavvio per aggiornare

Preferenze

Puoi modificare le impostazioni dell’editor nella finestra Preferences. Per aprirla, fai clic su File ▸ Preferences… oppure usa la scorciatoia Ctrl/⌘ Cmd + ,

Per maggiori dettagli, consulta il manuale delle preferenze

Preferenze

Log dell’editor

Se riscontri un problema con l’editor e devi segnalarlo (Help ▸ Report Issue), è utile fornire i file di log dell’editor. Per aprire la cartella dei log nel gestore di file del sistema, fai clic su Help ▸ Show Logs.

Per saperne di più, consulta il manuale su come ottenere aiuto.

Visualizzazione dei log

I file di log dell’editor si trovano qui:

  • Windows: C:\Users\ **Your Username** \AppData\Local\Defold
  • macOS: /Users/ **Your Username** /Library/Application Support/ oppure ~/Library/Application Support/Defold
  • Linux: $XDG_STATE_HOME/Defold oppure ~/.local/state/Defold

Puoi accedere ai log anche mentre l’editor è in esecuzione, se lo avvii da un terminale o dal prompt dei comandi. Per avviare l’editor, usa il comando:

# Linux:
$ ./path/to/Defold/Defold

# macOS:
$ > ./path/to/Defold.app/Contents/MacOS/Defold

Server dell’editor

Quando l’editor apre un progetto, avvia un server web su una porta casuale. Il server può essere usato per interagire con l’editor da altre applicazioni. La porta viene scritta nel file .internal/editor.port.

Il server fornisce una specifica OpenAPI all’indirizzo http://localhost:$(cat .internal/editor.port)/openapi.json. È un punto di partenza minimo utile per i flussi di lavoro basati su agenti.

Inoltre, l’eseguibile dell’editor dispone dell’opzione a riga di comando --port (o -p), che consente di specificare la porta all’avvio, ad esempio::

# Windows
.\path\to\Defold\Defold.exe --port 8181

# Linux:
./path/to/Defold/Defold --port 8181

# macOS:
./path/to/Defold/Defold.app/Contents/MacOS/Defold --port 8181

Metadati di installazione dell’editor

All’avvio, l’editor scrive le informazioni sul programma di avvio e sui percorsi di installazione in una posizione prestabilita. Le integrazioni con IDE di terze parti e altri strumenti possono usare queste informazioni per individuare gli editor Defold installati:

Sistema operativo Posizione
macOS ~/Library/Application Support/Defold/installations.json
Linux ${XDG_STATE_HOME:-~/.local/state}/Defold/installations.json
Windows %LOCALAPPDATA%\Defold\installations.json

Il file contiene un array JSON con un oggetto per ogni installazione nota:

[
  {
    "launcherPath": "/Applications/Defold.app/Contents/MacOS/Defold",
    "installPath": "/Applications/Defold.app",
    "lastLaunchedAt": "2026-07-06T12:34:56.789Z"
  }
]

Personalizzazione dell’aspetto dell’editor

Puoi modificare l’aspetto dell’editor usando stili personalizzati. Per saperne di più, consulta il manuale sulla personalizzazione dell’aspetto dell’editor.

FAQ

D: Quali sono i requisiti di sistema dell’editor?

R: L’editor utilizza fino al 75% della memoria disponibile nel sistema. Su un computer con 4 GB di RAM, questa quantità dovrebbe essere sufficiente per progetti Defold di piccole dimensioni. Per progetti di medie o grandi dimensioni, si consiglia di avere almeno 6 GB di RAM.

D: Le versioni beta di Defold si aggiornano automaticamente?

R: Sì. All’avvio, l’editor Defold beta verifica la disponibilità di aggiornamenti, proprio come la versione stabile di Defold.

D: Perché ricevo l’errore java.awt.AWTError: Assistive Technology not found quando avvio l’editor?

R: Questo errore è legato a problemi con le tecnologie assistive di Java, come il lettore di schermo NVDA. Probabilmente nella tua cartella home è presente un file .accessibility.properties. Rimuovi il file e prova ad avviare nuovamente l’editor. (Nota: se utilizzi una tecnologia assistiva che richiede la presenza di questo file, contattaci all’indirizzo info@defold.se per discutere soluzioni alternative).

Se ne parla in questa discussione sul forum Defold.

D: Perché ricevo l’errore sun.security.validator.ValidatorException: PKIX path building failed quando avvio l’editor?

R: Questa eccezione si verifica quando l’editor tenta di stabilire una connessione HTTPS, ma non è possibile verificare la catena di certificati fornita dal server.

Consulta questo link per maggiori dettagli su questo errore.

D: Perché ricevo l’errore java.lang.OutOfMemoryError: Java heap space quando eseguo determinate operazioni?

R: L’editor Defold è realizzato in Java e, in alcuni casi, la configurazione predefinita della memoria di Java potrebbe non essere sufficiente. In questo caso puoi configurare manualmente l’editor affinché allochi più memoria, modificando il suo file di configurazione. Il file di configurazione, denominato config, si trova nella cartella Defold.app/Contents/Resources/ su macOS. Su Windows si trova accanto all’eseguibile Defold.exe e su Linux accanto all’eseguibile Defold. Apri il file config e aggiungi -Xmx6gb alla riga che inizia con vmargs. Aggiungendo -Xmx6gb, imposti la dimensione massima dell’heap a 6 gigabyte (il valore predefinito è solitamente 4 GB). La riga dovrebbe avere un aspetto simile a questo:

vmargs = -Xmx6gb,-Dfile.encoding=UTF-8,-Djna.nosys=true,-Ddefold.launcherpath=${bootstrap.launcherpath},-Ddefold.resourcespath=${bootstrap.resourcespath},-Ddefold.version=${build.version},-Ddefold.editor.sha1=${build.editor_sha1},-Ddefold.engine.sha1=${build.engine_sha1},-Ddefold.buildtime=${build.time},-Ddefold.channel=${build.channel},-Ddefold.archive.domain=${build.archive_domain},-Djava.net.preferIPv4Stack=true,-Dsun.net.client.defaultConnectTimeout=30000,-Dsun.net.client.defaultReadTimeout=30000,-Djogl.texture.notexrect=true,-Dglass.accessible.force=false,--illegal-access=warn,--add-opens=java.base/java.lang=ALL-UNNAMED,--add-opens=java.desktop/sun.awt=ALL-UNNAMED,--add-opens=java.desktop/sun.java2d.opengl=ALL-UNNAMED,--add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED